Honda CRX Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
This just started to happen recently. I will be driving along and everything is good then all of a sudden my car will just start to slow down. I have my foot on the gas but its not accelerating or anything. Then in a couple seconds it starts to work fine again. Anyone know whats going on?
 

·
Registered
Joined
·
2,040 Posts
That sounds like an ignition problem to me. Fuel is usually more consistent.
I would start with the plugs and work backwards, testing things.
 

·
Registered
Joined
·
731 Posts
My take is you are losing spark momentarily. My crx was doing exactly what you describe 2 days ago. Luckily I have spare distributors and distributor parts.

I don't believe it's fuel related because say for example if your filter is clogged, it'll be fine in the low end but bog out high end. And it will do it pretty consistently. Same concepte with the air filter.
 

·
Registered
Joined
·
2,594 Posts
Maybe your TPS has formed a dead spot? You get to just the right throttle position and the sensor reading drops off. The ECU thinks the throttle has been closed and cuts fuel for coasting. Just a thought.
As for spark, if the car just suddenly dies like it's coasting (not firing on any cylinders), you would want to look at the distributor cap, rotor, ignition coil and/or ignitor unit. If it sputters like it isn't firing on one cylinder, try replacing the sparkplugs, distributor cap and sparkplug wires.
Has the check engine light come on at all while you're driving?
 

·
Registered
Joined
·
9,746 Posts
On my car, I have a new dizzy, and quality plug wires. The TPS is also known to be fine. It's more dependent on RPM and load than throttle position. I would still suggest to the OP to replace the plugs first since it's cheap and you should probably do it anyway.
 

·
Registered
Joined
·
79 Posts
i vote for general tune up if you havent dont so already

fuel filter, spark plugs, ohm out spark plug wires, etc..

edit: actaully after rereading your post agian, it might be your o2 sensor
as a bad o2 sensor will bog once you get on the gas but one you go WOT it kicks into open loop and bypasses the o2 sensor
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #10 ·
downest said:
Is your motor stock?
Yeah my motor is the D16A6.

Has the check engine light come on at all while you're driving?
No it hasnt.

actaully after rereading your post agian, it might be your o2 sensor
as a bad o2 sensor will bog once you get on the gas but one you go WOT it kicks into open loop and bypasses the o2 sensor
Do you know how I can check if my o2 sensor is still good?
 

·
Registered
Joined
·
317 Posts
does your tach ever bounce around when this is happening?
could be the ignitor...

Whenever I would run out of gas my car would do the same exact thing, when my fuel gauge was busted, it would start to cut out on the freeway or wherever and i knew it was time for a fillup!! lol

-Henry
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top