Honda CRX Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a b16a2 in my 90 crx and im runnin way to rich. my car is being robbed of power, and im gettin 250km to the tank. also when i do oil changes theers gass in the oil, and when im running the car really hard i backfire flames out of a one in two out muffler.

im running OBD1 injectors with the gray clip and no box, with a fuel press reg. the only mods really on the car are an aem hybrid intake DC 4-2-1 header and 2.5 exhaust. for an ecu i have a PR3 with is supposed to b perfect for the motor. i have an OBD1 P28 also but it has never been in the car.

I need suddestions on what needs to be done
 

·
Premium Member
Joined
·
4,512 Posts
Woah,Woah...if you have gas in your oil you have bigger problems...
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
im going to put on the oem fuel press reg and try that out. for the gass i the oil, its not alot just enuf to make it smell. im more worried about the power not being there and the flame situation
 

·
Registered
Joined
·
9,746 Posts
Bas is right. It's normal to get a little fuel vapour at least in the oil, have you ever seen the crap that goes through your PCV or catch can? I'm betting his FPR is set way too high, it's dumping excess fuel and running like crap, and a lot of that fuel is going right by the rings and out the exhaust.

Let us know what happens on the OEM FPR...

shooting flames FTW :twisted:
 

·
Premium Member
Joined
·
4,512 Posts
Ahh OK I was thinking he had copious amounts of raw fuel in his oil..Now thats a bad thing.
Yup swap that FPR back to stock and let us know what happens...
 

·
Registered
Joined
·
1,670 Posts
ollie said:
Ahh OK I was thinking he had copious amounts of raw fuel in his oil..Now thats a bad thing.
Yup swap that FPR back to stock and let us know what happens...
well not allways , i was haveing fuel issues ,(pump was way to big for my FPR lol ) and it killed the acelloator pump and all the fuel that was flooding the cylinders had no where to go so oviously its going to push it self past the rings

i changed the pump and all was good ,no more gas in the oil and no more running rich

im dealing with bike carb issues right now and im sure it will happen again we shall see :lol:

ddi you try the coil pack ???? i had one go on one of my car and it was really slugish and the smell of raw fuel was in the cabin of the car

good luck oh andi was shooting flames too ,i burned my moms leg :shock: :?
 

·
Registered
Joined
·
779 Posts
I had a similar issue once with raw fuel and very bad mileage. Turned out the MAP sensor was fubarred but wasn't throwing a code. Got a spare TB on and it solved the problem for me.

I doubt it's your issue tho. I also took my FPR off and put the stock one on and the car instantly got around 40kms more per tank.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
swapped the aftermarket fpr and ran some injector cleaner threw it, it seems better but is still rich. id live with how it is now but i have an e-test commin up in april so i think its still going to fail. other then pulling my vacume off the fpr what else can i do
 

·
Registered
Joined
·
551 Posts
have you ever thought that it could be a vac. problem my crx when i did the head gasket i got two of the vac. lines crossed and it ran rich and shot flames and the same with my 93 civic it shot like 2 foot flames when i let off and it backfired it ran RICH as crap!!!! i just could never figure out that problem though i did figure out my crx because i have had my motor out few times haha :oops:....................... :D
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top