Honda CRX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
354 Posts
Discussion Starter · #1 ·
Ok, I was trying to fix my climate control. Nothing works but the front window defogger. I replaced the unit with a unit I know was working. The same problems. I started messing around with the wiring running to the heater/ac unit and blam-O. I blew the battery main fuse (60amp) under the hood. It was so hot it melted the bottom of the fuse case to the fuse itself. So, what could be the problem. I'm going to try and find some fuses around town. What could have caused it to blow? Everything on the climate control worked but the little green lights above the buttons you push for feet/middle/top. I checked all the other fuses. Are there relays anywhere? Any suggestions would be great! Oh, this is on an 89 CRX DX. Oh, the rear defroster doesn't work either. The little light doesn't even come on.

BP
 

·
Registered
Joined
·
914 Posts
The only time i've blew my battery fuse was when I accidentally switched my battery cables. So possably, an always on positive cable from the climate control somehow got grounded and that would allow the surge of energy from the battery to flow.
 

·
Registered
Joined
·
354 Posts
Discussion Starter · #3 ·
Tiersin said:
The only time i've blew my battery fuse was when I accidentally switched my battery cables. So possably, an always on positive cable from the climate control somehow got grounded and that would allow the surge of energy from the battery to flow.
Well, I guess I'll check all the wire, make sure nothing is bare and touching metal.
Thanks
BP.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top