Honda CRX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
Never thought it could happen to me but it has. I was driving the CRX for the 1st time this year and went through a fairly large dip/hole/crack. (Roads here in Quebec are notoriously bad) and next thing I know my radio died and my clock only worked when I pressed the button. I also have the door ajar indicator that is showing on the dash. I got back to work & checked the fuse. It blew so I figured o.k. let's put a new one in. Well it blew the sec I put the car in ACC. I got to fixing it yesterday and decided to pull out the radio and clock. Well it still didn't help. The fuse blew once more. I also changed the battery and terminals because they were getting pretty crappy. So now I'm without a radio/clock the 15amp fuse still blows the Door ajar light comes on and I got to bring the car to the track Saturday. I also have a anti theft system that works great but seems to have wires going every which way. 4 Questions.
Where should I look for the problem... behind the in car fuse box? How should I look for the problem.. some special tool? Would I be taking a chance of getting stuck out at the track because of this electrical gremlin? Is there a trouble shooting electrical section for this kind of problem in the Honda manual?

Help please!!!
 

·
Registered
Joined
·
390 Posts
Look for any electrical wires that aren't 'terminated'. ex. anything that can cause a short in the electrical system. I had a hell of a time figuring what was blowing fuses for my speedo, lights, radio, etc... and come to find out when I installed my cd player years ago, I forgot to put electrical tape on one of the ends of the wires. the wire would touch metal every now and then and blow a fuse. it was hard as hell to diagnose because there weren't any symptoms. things would just stop working and with anything electrical it is usually good or bad, nothing in between; off or on... sounds like you have a short. hope this helps...
 

·
Registered
Joined
·
267 Posts
try checking your radios wiring harness..one of my wires got cut up by the metal brackets or something back there and shorted out real bad took me forever to find out but it was somehting that simple
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top