Honda CRX Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,509 Posts
Discussion Starter · #1 ·
My temperature gauge started to flutter upwards. Overheating? Well, I was traveling on the highway in near freezing weather with the heater on. But then I also had these other issues:

1) A/C Compressor failed to come on. I turned it on because that cuts on the extra fan.
2) Radio speakers cutting in and out.
3) Check Engine codes 1, 17, and 20!

After turning on and off the radio, the headlights and basically jiggling everything, all returned to normal. A/C compressor came on, radio worked normally, etc. I replaced the grounds and battery terminals about a year ago.

I have had problems with my main relay in the past. Could the loose contact be causing this while driving or am I looking at a short someplace?
 

·
Registered
Joined
·
779 Posts
You need new grounds. Sounds more like the 12v wasn't grounding if everything came on after a bit with no fires lol. Get the honda manual for our cars and then look at the electrical section for grounds. You would be surprised at how many grounds you need to look at and replace.
 

·
Registered
Joined
·
731 Posts
Near the main relay on the same structure the main relay bracket is mounted to. Your problem is one I've had before but that was due to an alternator that took a permanent bathroom break. Got good voltage?

Click THIS and see if anything applies.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top