Honda CRX Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Well, i bought a crx off a guy about a week ago, and before he sold it to me, it was broken into. He replaced the window, but the clips didnt come with. I got the clips already from a honda dealer, and now all i need to do is install them so the window will move straight. Does anybody know how to do this correctly? i dont want to break anything and make the door panel all wobbly. Thanks.
 

·
Registered
Joined
·
9,844 Posts
Its mostly Phillips screws that hold the panel on. Remove the door pull/cup, the trim behind the handle, the speaker grill... all those are visible screws. You will then find 4 screws under the speaker grill, a couple at the front, and one at the rear of the door. I usually work my way up from the bottom, carefully popping the clips free. Then the panel slides up and off the inner door frame. Depending on if the seatbelts are on the door or on the pillar, there may be one more plastic screw under the door holding the trim around the belt.
 

·
Registered
Joined
·
9,844 Posts
wow... can't believe I forgot that... lol

there is a clip underneath. There are tools to pop the clip off with, but you can use a small hook (paper clip should work) to remove it. rotate the handle upwards a bit... you will see a slot under the main section of the handle, and can grab the clip there. Then pull away from the center, the crank will fall off, along with the door panel.
 

·
Registered
Joined
·
23 Posts
Or you can use a rag to remove the clip from the window crank.

With the window closed and using a hand on each end of the rag to pull it tight, slip the rag underneath the crank between the plastic ring (next to the door panel) and the crank. Then shimmy the rag upwards and you should see the clip sliding up/off. You can then use a small flathead screwdriver to lift it the rest of the way off while holding on to the clip so it doesn't go flying or you can continue to use the rag and watch the clip go flying.

If the rag doesn't grab the clip the first time, try again going the opposite direction. It could be that the clip is installed upside down.

Hope that helps.

- C
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top