Honda CRX Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter · #1 ·
ok to start with my signals and hazards dont work,i check'd the fuse nothing happend,changed all the light with new ones nothing i think is the flasher relay(not realy shure)cuz the signal light switch got suck for a wile but it its fine now, i dont think thats it because the hazard button was fine but both things stopd working at the same time

another problem is my crx is giving me some problem starting up like it doesnt want to turn on but then it does, wen it reach's normal temperature it starts fine no problem,my guess at first was the engine timing was of(not were it should)but it starts perfectly when it reach's normal temp so now im guessing its got something to do with the fuel maybe the fuel filter not realy shure it can even be a fuel injector

i need help on this sorry that my english is bad if you dont understand it i will try to say it in another way thanks
 

·
Registered
Joined
·
317 Posts
I would guess you are having an issue with your "main relay"
it's a very large relay located behind the coin tray under your dash.
This can cause startup issues, due to age.

I think you already figured out what's going on with your flashers, imo.

-Henry
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #3 ·
thank you for the reply, is there any way to check?im guessing engine code?
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top