Honda CRX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3,255 Posts
Discussion Starter · #1 ·
ANd tell me if it goes straight from the trans to the wheel hub. Mine comes out of the trans and then cockeyes to the right stright to the hub. Not by alot but a little. And this is a new axle that *pops* and not clicks when I make a left turn.

I know it goes like

~l()---------()l~ The *()* being the CV joint...

Mine goes like

~l()_
--------()l~

Or something....
 

·
Registered
Joined
·
276 Posts
Angry said:
I know it goes like

~l()---------()l~ The *()* being the CV joint...

Mine goes like

~l()_
--------()l~

Or something....
Uhhh... I'm going to have to agree with Bobski on this one...return it and get another one.
 

·
Registered
Joined
·
3,255 Posts
Discussion Starter · #4 ·
Ehhh damn... :cry:

I shoulda mentioned this is the second one lol?
The axle looks as if my motor and trans are sitting crooked in the car...Which as far as I can tell they arent. The drivers side looks fine goes straight to the hub, the passenger doesnt.

Im starting to wonder if more damage was done than thought when it was backed into...
 

·
Registered
Joined
·
711 Posts
Angry said:
Ehhh damn... :cry:

I shoulda mentioned this is the second one lol?
The axle looks as if my motor and trans are sitting crooked in the car...Which as far as I can tell they arent. The drivers side looks fine goes straight to the hub, the passenger doesnt.

Im starting to wonder if more damage was done than thought when it was backed into...
Take it to a body shop, get them to check the frame...
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top