Honda CRX Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1,705 Posts
Discussion Starter · #1 ·
My newest addition to my CRX family had a dreadfully squeaky clutch pedal, and it was driving me crazy. If anyone else has this problem, it's actually a simpler fix than you might think.

First, disconnect the spring. Take a 14mm wrench and remove the nut that holds the pedal onto the pivot point. Remove the washer and the plastic bushing. Inspect the bushing for wear. Slide the pedal over and inspect the other bushing as well. Mine were ok, but they were completely dry (no grease). If they are damaged, order new ones from Honda. I slapped on a bunch of grease and reassembled the pedal. During reassembly of the spring, I discovered that one of the plastic bushings that the spring goes into was broken. I ordered a new one for $2.00 from Honda, and put everything back together again. My pedal is now absolutely silent.
 

·
Premium Member
Joined
·
2,047 Posts
I had a squeaky clutch pedal too, but when I replaced my clutch it mysteriously went away. Hmmm.
 

·
Registered
Joined
·
1,705 Posts
Discussion Starter · #3 ·
crxfisher said:
I had a squeaky clutch pedal too, but when I replaced my clutch it mysteriously went away. Hmmm.
If it starts squeaking again this winter when it's a little colder, you'll know what to do :)
 

·
Registered
Joined
·
247 Posts
my god damned hatch started squeaking again. the rubber seats have stopped working i guess... seems like whenever i lube the seal with silicone lube, it stops squeaking for the rest of the day, then the next day its back again.

anyone have any better rubber renovator than the silicone lube i use? something that will last a long time, and help me keep my sanity? i think i mentioned on some other thread about a parrot getting sodomized...

high fives to anyone who can save me from this menace
 

·
Registered
Joined
·
1,705 Posts
Discussion Starter · #6 ·
Stavros said:
my god damned hatch started squeaking again. the rubber seats have stopped working i guess... seems like whenever i lube the seal with silicone lube, it stops squeaking for the rest of the day, then the next day its back again.
Wrap the hatch hook with electrical tape. When it latches, this should hold it down a little better.
 

·
Registered
Joined
·
6 Posts
My hatch was squeaking and it turned out to be the hinges instead or the seal. I just shot some WD40 in them and the squeak quit.
 

·
Registered
Joined
·
1,705 Posts
Discussion Starter · #8 ·
chris said:
My hatch was squeaking and it turned out to be the hinges instead or the seal. I just shot some WD40 in them and the squeak quit.
Make sure you re-lubricate them after using WD-40. WD-40 is a solvent. It helped you clean out any gunk that was in there that was causing the hinge to bind, but it won't lubricate over the long term.
 

·
Registered
Joined
·
247 Posts
good advice. I have a few days off work because of Canada's Thanksgiving, so i will try the tape, and lubing the hinges.
 

·
Registered
Joined
·
945 Posts
I know this is an old post but i have the exact same problem just noticed it tonight in the drive thru. This helped a bunch.
 
1 - 10 of 10 Posts
Top