Honda CRX Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
So I just got my car back with a ZC swap and the car loves to wheel hop violently when shifting in 1st and 2nd. After a hard shift into 2nd gear, my tach suddenly stopped working correctly and the needle floats all over the place. I looked through my Hayes repair book but nothing ever discusses the "sender" for the tach. What does that tach read off of? It seems like something just backed out, because sometimes it works, then it just freaks out.
 

·
Registered
Joined
·
5,051 Posts
check the plugs, or at worst your distributor could need replacement. or at least just either the ignition coil or ignitor, i can never remember which is which and what does what...

but i solved my jumping tach issue by just replacing the distributor.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #5 ·
It occured right after I beat the hell out of my car. I don't think it could be the distributor. Also, the dizzy was just replaced when I did the swap last week. thanks for the ideas, ill consider them all when i start poking around at it.
 

·
Registered
Joined
·
5,051 Posts
my car ran great for months after i bought it used with a bouncing tach. i just lived with it until i just swapped out the distributor and that solved it.

my other crx crapped out on me at the top of laguna seca while i was running with a similar distributor problem. (you can completely coast down the hill from the corkscrew and into the pits, its that high up there) i had a spare in the pits. solved my issue then too.
 

·
Registered
Joined
·
2,597 Posts
The signal is output by the ignitor unit in the distributor. The ignitor is a common CRX failure item... The bouncing tach is frequently followed by ignition failure. The ignitor unit is responsible for cycling power to the ignition coil based on an ECU signal - it sorta does the grunt work of managing the coil. If it fails, no spark for you.
 

·
Registered
Joined
·
154 Posts
Yeah i have the same problem with my B18A

It works fine until 4k RPM, then the tach (and engine) starts flipping out and bouncing all over the place, and has a definite lack of power.

Also, when it gets too hot, the ignitor will choke with increasing frequency until it finally gives out. Then after 30-45mins of cooling it will work fine for awhile.

Tomorrow I'm going to the junkyard and picking up every ignitor i can find
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top