Honda CRX Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
9,746 Posts
Discussion Starter · #1 ·
I was thinking today about my VTEC pressure switch CEL problem. I've heard (mostly on HT) that VTEC uses a lot of oil, and I'm starting to think that my motor may indicate enough oil for an A6, but maybe not have enough for VTEC. What I mean is, the dipstick/bottom end is full, but it's designed for the non-VTEC head, thus needing less oil. So when I get to where I should have VTEC, there isn't enough in the head, and it doesn't switch over. Any ideas?
 

·
Registered
Joined
·
1,463 Posts
i dont no anything about vtec stuff but ur explanation makes sense of why ur getting that cel problem. sry if typing doesnt make sense.
 

·
Registered
Joined
·
3,255 Posts
Can you install a z6 oil pan and z6 (or y8 ) oil pickup on an a6?

Just throwing that out, I have no idea if they are even differnt.
 

·
Registered
Joined
·
9,746 Posts
Discussion Starter · #4 ·
Angry said:
Can you install a z6 oil pan and z6 (or y8 ) oil pickup on an a6?

Just throwing that out, I have no idea if they are even differnt.
Actually I didn't even think about that, perhaps someone who knows can shed some light... I have a spare Z6 oil pan and main girdle with the oil pickup. I think the pans are the same, but maybe the pickup is different. Matt showed me the flow rates on the D series oil pumps the other day, the A6 and Z6 are close to each other, and the Y8 flows a lot less than either (don't remember the exact numbers...).
 

·
Premium Member
Joined
·
4,512 Posts
Tom:I have a boosted mini-me that hits VTEC w/out problems.
As for your idea that the stock A6 pan not having enough oil capacity.hmm....I doubt that.
Considering that the Z6 capacity is 3.8 qts w/filter
and the A6 is the same I cant see that being a problem.
I know I'm coming out of left field here,but are we talking all this over a cel light on?
Please help me get up to speed and I can possibly help you.
 

·
Registered
Joined
·
633 Posts
Angry said:
Can you install a z6 oil pan and z6 (or y8 ) oil pickup on an a6?

Just throwing that out, I have no idea if they are even differnt.
Like ollie said I don't think the oil level is an issue either but to answer that question the Y8 pan is deffinitly different and I believe the Z6 is different also, but not completly sure
 

·
Premium Member
Joined
·
4,512 Posts
Not to sound condescending,but are you sure you dont have a bad VTEC solenoid?
Have you checked wire continuity? I have wired up stuff in the past only to find that the contact wasnt there.I'd make absolutely sure that you dont have a open circuit or a bad solenoid first.
 

·
Registered
Joined
·
9,746 Posts
Discussion Starter · #9 ·
Funny, I was actually revisiting this problem today while talking to someone. It's not the solenoid that's the problem AFAIK, it's the pressure switch. I know that before I wired in my VTEC wires, I would get a constant CEL for both the solenoid and the switch, but this only happens for the switch and only once I get to VTEC crossover.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top